Related Topics
OSPF Commands
To create or modify a routing configuration file, you must use the correct routing commands. This list includes the supported routing commands for OSPF. The sections must appear in the configuration file in the same order they appear in this list. You can also use the sample text found in the Sample OSPF Routing Configuration File.
For more information about Quagga commands, see Quagga Routing Suite Documentation.
Section | Command | Description |
---|---|---|
Configure Interface |
||
interface eth[N] | Begin section to set properties for interface | |
ip ospf authentication-key [PASSWORD] | Set OSPF authentication password | |
ip ospf message-digest-key [KEY-ID] md5 [KEY] | Set MD5 authentication key ID and key | |
ip ospf cost [1-65535] | Set link cost for the interface (see OSP Interface Cost table below) | |
ip ospf hello-interval [1-65535] | Set interval to send hello packets; default is 10 seconds | |
ip ospf dead-interval [1-65535] | Set interval after last hello from a neighbor before declaring it down; default is 40 seconds | |
ip ospf retransmit-interval [1-65535] | Set interval between link-state advertisements (LSA) retransmissions; default is 5 seconds | |
ip ospf transmit-delay [1-3600] | Set time required to send LSA update; default is 1 second | |
ip ospf priority [0-255] | Set route priority; high value increases eligibility to become the designated router (DR) | |
Configure OSPF Routing Daemon | ||
router ospf |
Enable OSPF daemon | |
ospf router-id [A.B.C.D] | set router ID for OSPF manually; router determines its own ID if not set | |
ospf rfc1583compatibility | Enable RFC 1583 compatibility (can lead to route loops) | |
ospf abr-type [cisco|ibm|shortcut|standard] | More information about this command can be found in draft-ietf-abr-o5.txt | |
passive-interface eth[N] | Disable OSPF announcement on interface eth[N] | |
auto-cost reference-bandwidth[0-429495] | Set global cost (see OSPF cost table below); do not use with ip ospf [COST] command | |
timers spf [0-4294967295][0-4294967295] | Set OSPF schedule delay and hold time | |
Enable OSPF on a Network | ||
*The area variable can be typed in two formats: [W.X.Y.Z]; or as an integer [Z]. | ||
network [A.B.C.D/M] area [Z] |
Announce OSPF on network A.B.C.D/M for area 0.0.0.Z |
|
Configure Properties for Backbone area or Other Areas | ||
The area variable can be typed in two formats: [W.X.Y.Z]; or as an integer [Z]. | ||
area [Z] range [A.B.C.D/M] | Create area 0.0.0.Z and set a classful network for the area (range and interface network and mask setting should match) | |
area [Z] virtual-link [W.X.Y.Z] | Set virtual link neighbor for area 0.0.0.Z | |
area [Z] stub | Set area 0.0.0.Z as a stub | |
area [Z] stub no-summary | ||
area [Z] authentication | Enable simple password authentication for area 0.0.0.Z | |
area [Z] authentication message-digest | Enable MD5 authentication for area 0.0.0.Z | |
Redistribute OSPF Routes | ||
default-information originate | Share route of last resort (default route) with OSPF | |
default-information originate metric [0-16777214] | Share route of last resort (default route) with OSPF, and add a metric used to generate the default route | |
default-information originate always | Always share the route of last resort (default route) | |
default-information originate always metric [0-16777214] | Always share the route of last resort (default route), and add a metric used to generate the default route | |
redistribute static | Redistribute firewall static routes to OSPF | |
redistribute connected | Redistribute routes from all interfaces to OSPF | |
redistribute connected metrics |
Redistribute routes from all interfaces to OSPF, and a metric used for the action |
|
Configure Route Redistribution with Access Lists and Route Maps | ||
access-list [LISTNAME] permit [A.B.C.D/M] | Create an access list to allow distribution of A.B.C.D/M | |
access-lists [LISTNAME] deny any | Restrict distribution of any route map not specified above | |
route-map [MAPNAME] permit [N] | Create a route map with name [MAPNAME] and allow with a priority of [N] | |
match ip address [LISTNAME] |
|
See Also
About Open Shortest Path First (OSPF and OSPFv3) Protocol