RIP Commands (FRR)
To create or modify a routing configuration file, you must use the correct routing commands. This topic includes a list of example RIP routing commands.
In Fireware v12.9 or higher, Fireware uses the Free Range Routing (FRR) routing engine, which replaces Quagga. If your configuration includes Quagga commands for dynamic routing, those commands work after you upgrade. Some FRR commands appear in a different section than in Quagga.
For RIP code samples, go to Sample RIP Routing Configuration File (FRR).
To configure RIP, go to Configure IPv4 Routing with RIP.
Fireware v12.8.x or lower uses the Quagga routing software suite. For a list of example Quagga commands, go to OSPF Commands (Quagga).
Example RIP Commands (FRR in Fireware v12.9 or Higher)
This list includes example FRR commands that you might include in your RIP configuration. For a complete list of FRR commands, go to the FRRouting User Guide.
This list includes the supported routing commands for RIP v1 and RIP v2 that you can use to create or modify a routing configuration file. If you use RIP v2, you must include the subnet mask with any command that uses a network IP address or RIP v2 will not operate. The sections must appear in the configuration file in the same order they appear in this list.
For greater security, we recommend MD5 authentication instead of simple authentication. Simple authentication passes the authentication string in plain text. Commands for both MD5 and simple authentication are shown here.
The sections must appear in the configuration file in the same order they appear in this table.
Section | Command | Description |
---|---|---|
Set simple password or MD5 authentication on an interface |
||
key chain [KEY-CHAIN] | Set MD5 key chain name | |
key [INTEGER] | Set MD5 key number | |
key-string [AUTH-KEY] |
Set MD5 authentication key |
|
Configure interfaces | ||
interface eth [N] | Begin section to set authentication type for interface | |
ip rip authentication string [PASSWORD] | Set RIP authentication password | |
ip rip authentication mode text | Use simple authentication | |
ip rip authentication mode md5 | Use MD5 authentication | |
ip rip authentication mode key-chain [KEY-CHAIN] | Set MD5 authentication key-chain | |
|
ip rip send version [1/2] | Set RIP to send version 1 or 2 |
ip rip receive version [1/2] | Set RIP to receive version 1 or 2 | |
version [1/2] | Set RIP version to 1; default is version 2. | |
no ip rip split-horizon | Disable split-horizon; enabled by default | |
Configure RIP routing daemon and configure interfaces and networks | ||
router rip |
Enable RIP daemon | |
default-information originate | Share route of last resort (default route) with RIP | |
neighbor [A.B.C.D/M] | ||
network [A.B.C.D/M] | ||
no network eth[N] | ||
passive-interface eth[N] | ||
passive-interface default | ||
version [1/2] | Set RIP version to 1 or 2 (default version 2) | |
redistribute static | Redistribute firewall static routes to RIP peers | |
redistribute connected | Redistribute routes from all interfaces to RIP peers | |
redistribute connected route-map [MAPNAME] | Redistribute routes from all interfaces to RIP peers, with a route map filter (mapname) | |
redistribute ospf | Redistribute routes from OSPF to RIP | |
redistribute ospf route-map [MAPNAME] | Redistribute routes from OSPF to RIP, with a route map filter (mapname) | |
redistribute bgp | Redistribute routes from BGP to RIP | |
redistribute bgp route-map [MAPNAME] | Redistribute routes from BGP to RIP, with a route map filter (mapname) | |
Configure access lists | ||
access-list [LISTNAME] [PERMIT|DENY] [A,B,C,D/M | ANY] |
Create an access list to allow or deny redistribution of only one IP address or for all IP addresses | |
Configure route maps | ||
route-map [MAPNAME] permit [N] | Create a route map with a name and allow with a priority of N | |
match ip address [LISTNAME] | Match if route destination is permitted by access list. | |
Enable SNMP Queries (Fireware v12.10 and higher) | ||
agentx | Enable SNMP queries for dynamic routing. SNMP queries can result in high CPU usage if there is a large number of routes. RIP OID — .1.3.6.1.2.1.23 |
About Routing Information Protocol (RIP and RIPng)